Opened 4 weeks ago

Closed 4 weeks ago

#7 closed enhancement (fixed)

Remove enable_shared_from_this from DipoleSource

Reported by: tirons Owned by: tirons
Priority: major Milestone: milestone1
Component: component1 Version:
Keywords: Cc:

Description

Python wrappers struggle with enable_shared_from_this, as found in DipoleSource?, this may also be linked to a performance regression from previous versions of Lemma which used in-house reference counting.

Tasks: test the use of raw pointers from within Lemma classes using shared_ptr->get() rather than the current extensive use of short lived copies. In all cases verify that the pointer cannot be deleted. This only occurs during calls to single computationally-intensive methods, and there should be no issues.

Change History (2)

comment:1 Changed 4 weeks ago by tirons

  • Owner changed from somebody to tirons
  • Status changed from new to accepted

comment:2 Changed 4 weeks ago by tirons

  • Resolution set to fixed
  • Status changed from accepted to closed

This has been remedied through the use of raw (this) pointer. In this case it will be safe due to the parent class mandated to stay in scope during calculation.

Note: See TracTickets for help on using tickets.